macd顶背离选股公式 这个指标什么意思

由于macd指标对趋势的判断一目了然,因此,也有许多朋友称它是“技术指标之王”。那么,macd顶背离选股公式是什么?还有这个指标什么意思?下面一起来详细了解一下相关知识。

MACD是指数平滑异同移动平均线的英文简称,这是为弥补移动平均线经常会发出虚假信号的不足,利用对股票价格的收盘价进行平滑处理,求出加权平均值以后再进行计算手段,从而得到的一种趋向类指标。

MACD是由三条线和红绿色柱体构成,黑色线是DIF线,称之为快线;紫色线是DEA线,称为慢线。macd指标中间的一条直线是零轴,红色和绿色的柱体是能量柱。

零轴:上方为正值区域,属于多方领域;下方为负值区域,属于空方领域。曲线:DIF为快线,DEA为慢线。柱体:红色柱线运行在正值区域;绿色柱线运行在负值区域。

1、隔山背离

中间那个顶,我们就称为“山”,左右两个次高点,中间“隔”着一座“山”。前提是左边的“半山腰”与右边的“半山腰”差不多在一个水平位置,左边所对应的MACD红柱,右边对应出现绿柱,就称为“隔山背离”。

2、单阳背离

利用一根阳线来分析背离情况,首先我们看到是一个在日K线下的阳线,本应该是对应的红色线柱,有在一定的特殊的情况,就出现绿色的线柱从而也就造成的单阳背离的现象。

3、单阴背离

利用一根阴线来分析背离情况,首先我们看到是一个在日K线下的阴线,本应该是对应的绿色线柱,有在一定的特殊的情况,就出现红色的线柱从而也就造成的单阴背离的现象。

4、顶背离

当股价K线图上的股票走势一峰比一峰高,股价一直在向上涨,而MACD指标图形上的红色柱构成的图形也开始缩小甚至变成绿色,即当股价的高点比前一次的高点高,而MACD指标的高点比指标的前一次高点低,这叫顶背离现象。顶背离现象一般是股价在高位即将反转转势的信号,表明股价短期内即将下跌,是卖出股票的信号。

macd顶背离选股公式源码

DIFF:EMA(CLOSE,12)-EMA(CLOSE,27);

DEA:EMA(DIFF,9);

MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK2;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A1+1)CLOSE AND DIFFREF(DIFF,A1+1) AND CROSS(DIFF,DEA);

STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORFF00FF,LINETHICK4;

DRAWTEXT(底背离,0.12,’底背离’),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1)CLOSE AND REF(DIFF,A2+1)DIFF AND CROSS(DEA,DIFF);

顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK4;

{

选股公式:

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,27);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA), COLORSTICK,LINETHICK2;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:REF(CLOSE,A1+1)CLOSE AND DIFFREF(DIFF,A1+1) AND CROSS(DIFF,DEA);

}

本文标题:macd顶背离选股公式 这个指标什么意思文章由作者阳光知识网投稿,如果觉得有帮助欢迎收藏转发!
声明:本站部分文章来自网络,如无特殊说明或标注,均为本站原创发布。如若本站内容侵犯了原著者的合法权益,可联系我们进行处理。分享目的仅供大家学习与参考,不代表本站立场。